ARTextureMaterial with alpha gives no transparency

kudanar

#1

Hello there,

To get transparency in my 3D model, I’m using an ARTextureMaterial with alpha set. But when I apply the material on a ARMeshNode in my 3D model, I don’t see any transparency. When I look at the Kudan AR documentation I thought this should be possible.

Does anyone have any ideas about this issue?


#2

I just found out I should set property isTranslucent, inherited from ARMaterial, to YES. That gives me transparency! And the alpha setting is used to decide how much transparency.


#3

We’re glad you were able to solve your issue. Hopefully your solution will also help out anybody else with the same problem.